Custom actions not sending data to webhook

Gotcha. I also noticed that the custom action type is an Update action and the method is a POST. I’m not sure if this will make a difference, but even on a Webhook that triggers an update of some kind, I think the Custom action type should be a “Create” with a POST method.

Also, when you had it set up that way before, did you also have the intermediate screen?

I don’t think the Create vs Update thing matters at all since that doesn’t get included with the request content.

I didn’t have the intermediate screen before, was only created for the purpose of triggering that action after the user was updated from the previous screen.

Bumping this. Haven’t heard from @Devops in days. Are you still looking into this?

Hi @zakakatz and sorry for the late reply :wave:

So you fired off a test request with an example value for each of your data fields and you’re getting this on Integromat?

248ff2992bf93626057be8b469b80fe57e9c7621_2_501x500

If this is the case, please double check you have set your data fields to the appropriate String or Number value.

If you feel that all has been fully tested on your side, you can submit a support ticket here :point_down:

My test request does not reproduce the issue. I have re-established the webhook data structure as you suggested, but we are still seeing the same issue from users in the wild.

Ok, thanks for letting me know, well the problem is definitely within a “step” from the moment your Custom Action is triggered, could be a collection lookup problem or some parsing issue to the request body.

All I can suggest now is to submit a support ticket as I can’t really debug this without reproducing your “exact” setup.

Please let me know in this thread what the issue was (really curious) :wave:

I’m still thinking if you keep the intermediate screen and then add the Custom Action to the Done button it will send the data more consistently. I know it sounds crazy, but we don’t know if it will work until you try it will the intermediate screen.

Yeah, I agree…I don’t see how something is “broken” (but you never know).

@zakakatz if you have the “strength left” to test this out that would be one more thing off our debug checklist.

But you will need to create a custom form with input fields if you want to parse the data without doing a Db lookup.

1 Like

Found another custom action in our app where this is happening.

When the user clicks the “Let’s go” button we have this custom action setup to send the logged in user’s email address to a webhook in integromat, where Integromat searches our external DB for that email and returns the necessary information to complete the user’s profile on Adalo in the webhook response. There is a subsequent action that updates the logged in user with those webhook responses.

On the ingromat side, we are seeing cases where no email is being sent in request:

Can you please stick to your original workflow posted on this thread?
Did you try our suggested solution?

Yes I tried it. I’m still monitoring for the issue but I thought that another example of pretty much the exact same problem (Custom action not sending correct data to webhook) was relevant to this issue.

Thanks for pointing that out :blush:,

The above workflow is not optimal as multi-steps actions should be executed in Integromat and not Adalo. (Adalo is not currently designed like Zapier, Parabola or Integromat for sequential steps)

Well, comming back to your issue, this still might be a bug, did you submit a ticket?

The workflow I’m using there is all conditional logic for each action. nothing in each action is reliant on a previous step, with the exception of the update user actions which use information from each custom action that has the same set of conditional criteria to run.

Could very well be a bug, but just in case, could you:

  1. See what it does in a private window?
  2. Send a screenshot of your custom action request setup
  3. Send us a video explaining the workflow?

So let’s not get confused here, when you create a custom action you initialy invoke an “Adalo backend workflow” nothing to do with your Integromat workflow.

Like I said before if you feel that you tried everything on your side (with our input), please feel free to contact Adalo’s support as this still might be a bug.

Else, I’m more than happy with (@pfordmedia by my side) to try to help you solve your issue…but all we need from you is to reply to our questions so we can 101 debug this :blush:.

I’ve submitted a ticket, and recorded this video showing the workflow:

  1. same thing in a private window.
  2. See video for custom action request setup
  3. see video
1 Like

Ok so here is an interesting development. This issue just came up again on the original workflow, however with NEW userID and offer ID values but still with blank values for the other fields:


An interesting development because this particular offer record was created today, and the user clearly tried completing that form to apply their address information to the record, but the custom action did not send the values the user entered.

Thanks for the video @zakakatz :blush: :raised_hands:

So let’s start debugging this:

1: Keep your request as POST

2: Please add to you header: Name=Content-Type, Value=application/json

3: Your JSON body format is not optimal should be:

{
“CXCD”:Space"CXCD",
“ORDER”:Space"ORDER",

}

You should redetermine your data structure just to be safe.
Can you tell me if this solved the problem?

Just would like to add that there is a problem with your webhook as you have a Header array.
Normally you should not have this Headers object only Bundle 1.

Did you set up the right Webhook in Integromat? (Custom webhook)

In integromat, I have enabled the option to add the request headers from Adalo to the body of the webhook, hoping to uncover any issues with the requests being sent:

As you can see, the content-type header was already correctly identified but I added that header anyway as you suggested.