GET ALL error even though the API response was successful

Hi everyone!

I’m new to Adalo and am trying to connect my external API to my app. Some information about my API:

  • Generated using
  • Using a synthetic key, tenant name and content-type header
  • Is an execute style API using POST method only

Step 1:

Step 2 (the API uses only POST so I have just changed all methods to POST and entered my endpoint for each):

When I test the above, I am able to see a successful API response, but I notice that there was an error from Adalo when getting all.

What’s wrong and how do I fix it?

Any help appreciated!

Thank you,

Hi Sadhana,

I think you would not need to change all endpoints to Post. Keep them like that and test it. If you get this same error then you need to add a result key on the get all endpoint. I think that should be response_data and outputs.

But you said this is a Post one and Custom actions will be good for that!

You want to create a record?

Thank you

Hi @dilon_perera - thanks a ton for a reply! I’ve been trying for a while now ahaha.

I have actually tried to keep all other endpoints to the default method:

I still get an error:

Yes, you are right, it is a post endpoint only. I can try custom actions - do you know how I can get started? Also, do i need a collection to work with custom actions? How do I get a collection if Adalo doesn’t allow me to?

Thanks so much!