In app Purchase TestFlight doesn't work


I try to test my implementation of IAP in my IOS version. I have filled the informations in the IAP purchase section in AppleConnect.

My app has not been submited because I only test on TestFlight first. Is it normal that the in app purchase doesn’t work even in TestFlight ?

I have the message error : “E_DEVELOPER_ERROR”

Anyone know about this error ?

Thanks a lot

1 Like

Anyone on this forum has implemented IAP ??

I am getting the same issue. I submitted a support ticket too. I still haven’t seen a solution. Please post here if anyone has solved this. Thanks.

1 Like

I’m still stuck has anyone solved this issue?

1 Like

In order for your IAP purchases to work on testflight, you need to have your Bank information submitted and connected by Apple. It will not work before that, and you will get the E_DEVELOPER_ERROR.

Of course, Apple is very cryptic in their messages. So it could be something else. I would start verifying that.



Thank you @aestevam. I have already submitted BANK Informations.

What do you mean by “connected by Apple” ? Auth ? If yes already implemented of course.

Thanks for your time

It means apple have to say your info is active.
Happy hunting!

I made progress on this. I was able to get it working on one screen but not another. I have been working with Adalo support but they haven’t been able to figure it out yet. Does anyone else have updates?

This was not the solution in my case. All of this was set up and Apple support verified it.

For my part, it was actually the documents needed by Apply for the US Taxes. It is working well now thanks to @aestevam !

Cool. Glad to hear it works for you. I have it working on one screen but it doesn’t work on another. My case seems to be a bug in the Adalo component or platform. Support seemed to confirm but they have been able to solve yet.

I would be interested to know more about the bug, @brian-augusto . So you have working in one screen but not on another? how many screen is your app? and what is different in the not working screen in terms of setup?

Thanks for asking. The app is maybe 20 screens. I have IAP on two identical pages. The button is in a list and driven from DB. There isn’t a difference that I or the support team can tell. I actually cloned the list and button from the screen that works but it still doesn’t work.

The most frustrating part of this issue is the support. The communication about anything being done on this issue has been minimal at best.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.