A simple form is not working

Hi everyone, I am new here, great to meet you.

Had a pretty frustrating couple of days on Adalo. Two things:

  1. A simple form all of the sudden no longer works: I input all the fields as I always do, click on create item, and nothing. I’ve logged in and out a million times etc.

  2. Arrange function: can’t seem to make it work…send back and bring forward don’t do anything. I know there was a thread a few months back…just wondering if this has been fixed. still doesn’t work for me.

Thank you!

Yidi

Hi Yidi,

Welcome to the Community! :partying_face:

Sorry for the frustration.

1.) Did you try removing the form and re-adding it? If that doesn’t work, please add screenshots of how you have the form setup.

2.) I’ve had this same problem. It’s intermittent, sometimes it works and sometimes it doesn’t. Maybe after refreshing the page it might work.

Thanks for the response James!

I redid the form three times already and it still doesn’t work.

It also happened pretty suddenly. Nothing in the app was changed, and it just stopped working.

It’s a pretty simple form. I have a database called items, and the form lists out all the fields.

So I just tried to build this form back up field by field. and it seems like the problem is when i get to a field that’s a drop down (essentially linking it to another collection of data), that’s when the form stops working.

Any thoughts on why that’s happening?

Could you take a screenshot of the collection that you are using for the drop down in the form? And how it’s setup?