Adalo Editor not opening my App

Hi All,

I am really frustrated by Adalo’s issue that it cannot open my Main App most of the time. While my testing (or small) Apps for experimentation can open easily.

I am not sure what is the issue with Adalo.

I have already dedicated on Laptop for Adalo App, because if I try to login from another computer, then my App will not open from a new computer.

Today by mistake I closed my App, and now trying hard to open my App but not successful.

Note, that Adalo editor, itself opens, but my App cannot load , and this continues forever.

Any help will be greatly appreciated!!!

1 Like


For my main App only, Adalo gives error that "You’re Offline! Your apps will not save until you reconnect."

Happening to me too. I tried everything from clearing cache and data, restarting browser and PC, but still, nothing is working. Anyone can help?

1 Like
1 Like

Actually, I am using a VPN but still not working. Is this because I am not a pro user yet? Or it’s a bug from Adalo?

No difference between paid and free plan in my experience, at least for now.

Another tip would be to open them during early morning when everyone else are not using internet, like 4am or 5am, after that you can put the computer to sleep and later continue the work at appropriate time.

I am guessing there is a very quick timeout from the cloud server that people with high speed internet and nearby to the cloud server did not experience this, so we must find the nearest vpn at less congestion time to avoid this timeout.


Okay, will try your suggestion to open the editor again early in the morning. I have tried all VPN locations available but that didn’t help. So I decided to submit a ticket and will update this thread once I find a solution :+1:

My Editor finally working. And now I am very careful that I do not close the Browser window, otherwise it might take very long to re-open the editor.


I found this issue at:

  • Peak Times
  • Poor Internet Connection
  • Weak WiFi connection
  • Browsers that timeout quickly

Through trial and error a few things worked for me:

  • Use a browser that doesn’t time out eg. Firefox
  • Use Wire Ethernet connection for the initial Load up of the App. Use VPN if this doesn’t resolve, try a few different
  • if you have a lot of Images (make sure format so they are tiny), that are uploaded into the editor, or you’re loading Lottie Files, GIFS, Images URLS these will all make the app slower to load. Obviously the more screens etc the more difficult to load.
  • Sometimes it doesn’t matter how long you wait it won’t load, so there must be a timeout Adalo serverside also - so if it doesn’t load within a minute or two it likely won’t load. Refresh.
  • I’ve found that the yellow line can disappear if you pan in and out across most of the screens to load components and text etc (could be completely irrelevant but seems to work for me).

The only thing from the above I can say for sure that works, is super fast internet, VPN and a browser that doesn’t time out.


I agree with @iAppsNi if we’re building large apps we need fast internet to load the app in the editor

After I contacted Adalo support I told them to delete some of my app’s screens and they suggested sending me the clones of 2 apps with deleted and non-deleted screens. This helped me proceed with work in the editor.

As @k86305 said, for those who are experiencing a similar issue, once you are able to load the app again NEVER close the browser window.

This is difficult if we are collaborating with other builders.

I try firefox too, but seems the timeout comes from cloud server not browser client.

Fortunately Adalo can share database among apps, so if one app had enough screens, we can create another one.

1 Like

True, I hope they resolve this issue very soon. I have worked with other online editors (for websites) they didn’t have this issue. Not sure though if apps editors are different.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.