Android Build error code 1 (signal: null)

Hello to everybody,

Honestly : I’m going crazy!
I have spent 8 h trying to solve this problem with my app on Android: error code 1 (signal: null)
It worked a couple of days ago and now, after some minimal modification, I get this error. I even tried to build a very basic premade app from Adalo but also those are giving the same issues.
Even more: if I add an image it is also giving: stderr | ERROR RETRIEVING FILE: { (PNG or JPEG)
What is going on?!

here some extract:

exec error: Error: /home/gradle/scripts/ exited with error code 1 (signal: null)
Error in buildAndroid: Error: /home/gradle/scripts/ exited with error code 1 (signal: null)
at exec (/home/gradle/scripts/lib/exec.js:124:13)
at async buildAab (/home/gradle/android/buildAndroid.js:302:3)
at async callback (/home/gradle/android/buildAndroid.js:370:55)
at async run (/home/gradle/scripts/lib/steps.js:25:53)
at async Object.execute (/home/gradle/scripts/lib/steps.js:41:50)
at async buildAndroid (/home/gradle/android/buildAndroid.js:373:3)
at async Queue. (/home/gradle/android/index.js:84:9)




stderr | error SyntaxError: /tmp/build-Rv3Sa1/AdaloApp/featureFlags.js: Unexpected token, expected “,” (2:29)
stderr |
stderr | e[0m e[90m 1 |e[39m e[36mexporte[39m e[36mdefaulte[39m {e[0m
stderr | e[0me[31me[1m>e[22me[39me[90m 2 |e[39m e[32m’dbAssistantModel’e[39me[33m:e[39m [object e[33mObjecte[39m]e[33m,e[39me[0m
stderr | e[0m e[90m |e[39m e[31me[1m^e[22me[39me[0m
stderr | e[0m e[90m 3 |e[39m e[32m’has-published-apps’e[39me[33m:e[39m e[36mtruee[39me[33m,e[39me[0m
stderr | e[0m e[90m 4 |e[39m e[32m’has-responsive-sidebar’e[39me[33m:e[39m e[36mtruee[39me[33m,e[39me[0m
stderr | e[0m e[90m 5 |e[39m e[32m’hasAlignmentTools’e[39me[33m:e[39m e[36mtruee[39me[33m,e[39me[0m. Run CLI with --verbose flag for more details.
stdout | SyntaxError: /tmp/build-Rv3Sa1/AdaloApp/featureFlags.js: Unexpected token, expected “,” (2:29)
stdout |

I’ve tried to create new Firebase projects to check from that side, but nothing.
What to do? Any suggestion?


I am also experiencing these problems, it should be an official Adola problem, you can contact Adola in order to bring this problem to their attention, hopefully Adola will fix it soon…

1 Like

You think?!
It looks like we are only in 2 at the moment…
I’ve open a ticket hours ago and nothing yet. :frowning:

Thanks for writing us about this!

We are aware of the issue, and the team is actively investigating the cause. You can read more about this on our Adalo | Status Page.

We will provide updates there as soon as we know more!

1 Like

We are happy to announce that the issue with our build servers has been resolved, and builds are now succeeding for both iOS and Android platforms! We apologize for the inconvenience this may have caused and thank you for your patience while we worked to resolve it. You will need to push a new build for the changes to take effect.

1 Like

@Adalo_CXTeam I still can’t create iOS versions, it’s been queued for an hour…

Worked for me.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.