Android build failed (Icon issue in the App)

Hi, I am facing an issue on Android version.
I build an Android app and tried a testing its build version.
But all icons in the app are disabled as attached the pic.

I tried build to confirm this issue 2 times, but every time the issue appears.
Does anyone know the solution?

Steps as follows

  1. Move to a saved old version from new.
  2. Modified the old version
  3. Build the android version
  4. Checked it on a Pixel 4 → Found issue.
  5. Build again
  6. Checked it on a Pixel 4 → Issue again
    ※All icons are working properly on the preview.
1 Like

A shared link would be helpful. Are the icons top and bottom in an app bar or tab bar? Are the icons native or imported and, if the latter, are they directly imported or served through the database?

The same thing happened to me, all the icons are like this with an x, all the input or down borders don’t appear either… I already compiled it twice

I used adalo’s, button>icon

I am facing same issue.

It seems, Adalo’s native ICONs are converted into equivalent Chinese Characters. (But I am not sure).

Attached is the picture of my ICONs, (seems something like Chinese)

1 Like

All icons are from adalo components.
I haven’t used any imported icon like png, jpg.

the same for me

Another thread is running with the same problems as well. Seems like everyone is facing the issue. Have you submitted a support ticket ?

Hi, I haven’t submitted it yet.
I will do that soon.

And as the additional information, the build for iOS is successful properly.
There is no icon issue.

Facing the same exact problem, its crazy that there is no announcement from Adalo to acknowledge this. Its happening on all Android devices…

1 Like

I think because Adalo is not acknowledging the problem, we will lose trust in their Status system. What good is it if it doesn’t report and acknowledge anything ?

We understand that there are bugs but all we ask for is an acknowledgement, an assurance that we’re fixing it and an estimated timeline. But Adalo prefers to be quiet about it.

I am just as surprised as you are … It has been more than 24 hrs and yet, no acknowledgment from Adalo whatsoever! I cannot even revert back to my old builds at the moment, what a horrible user experience for our app users … Android one thing, iOS another thing

We’ve sent out a fix for this issue - please rebuild your apps and let us know if you’re still seeing this? The fastest method would always be to Submit a Support Ticket. Thank you!


I have just tested it and rebuilt. The icons are ok.



Thanks for confirmation.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.