API test doesn't finish

Hi everyone,

I’ve been working on a few custom actions and noticed that my API tests never seem to finish, even after the correct data has been pass to integormat. Has anyone run into similar issues and know how to solve this?

As a result, i can’t save any changes to my custom action. Thank you!

Yidi

Hi @Ycampbell

Im rinning into the exact same issues. I tried to test in Postman to be sure yhe code worked and it did which means there’s something wrong on Adalo’s end.

Ive submitted a ticket but they havent provided any solution still.

I had issues with it yesterday and gave up. Didn’t bother with a support ticket :confused:

Hopefully they get it figured out.

Sorry you’re having issues on this! Here are a few things to test here:

  1. Does the request ever show up in the Make logs?
  2. Do you have a webhook response module at the end of your scenario?
  3. Is the first module in the scenario a webhook module?
  4. Try a different browser or use a private/incognito window to see if that improves things.
  5. Ensure the Content-Type header is used and the value is set to application/json
  6. Try removing any symbols that may be in your test values.
2 Likes

Hi Patrick, thanks for the reply.

It looks like the problem is impacting every single custom action. and these custom actions have been in place for a few months…nothing changed on my end. Everything in Prod works…which we released on 7/2. Nothing in Dev works.

  1. the requests all show up in Make…Adalo just can’t seem to get out of the making the request…so no action after the custom request is working
  2. No, I do not have a response module at the end of any of my scenarios.
  3. Yes, always
  4. Have tried everything…same problem
  5. I just tried that with one custom action…same problem
  6. there are no symbols as my test values. The same scenarios have been in place for months…feels like something on your end suddenly stopped working at least for my account and seems like for a few others as well.

I’ve been speaking to Jessi Frye on your team re. the ticket I opened just FYI.

Thank you!

Hi everyone,

I’d recommend looking at browser console logs as well and see what’s happening there. You can open the console before pressing “test request”, go to Network tab and see what’s happening. Maybe this can shed some light on the root cause of the problem.

Best regards, Victor.

P.S. I have had a very weird case recently - a button with custom action stopped working. The reason for it was that in an API call to a custom action (POST https://adalo-database-api.herokuapp.com/custom- action/CUSTOMACTIONID/execute), the CUSTOMACTIONID was null (instead of a numeric ID).
Discovered that only in the logs. Recreating the action and button from scratch fixed the problem.
Patrick @pford seems some editor changes broke some things :slight_smile:

2 Likes

If anyone else is experiencing this same issue, can you please submit a ticket using this Support Form with as many details as possible to help us narrow down the cause.

Thanks in advance!

2 Likes

Hello, I have the same issue. Ticket submitted.

At the moment I have detected that I have this problem with all the actions that include a call to MAKE (customa action) and the problem is that it stops the execution of the rest of the actions and does not allow to continue browsing in the desktop and webapp versions.

2 Likes

Hey @breadflix.es, I’ve tested your app and the problem seems to be fixed. Could you confirm it on your end? Also feel free to delete the most recent bread request under the email of daniel.costa@adalo.com.

Yes, it seems that everything works ok.
Thanks,
Enrique

1 Like

Face the same issue before and now all are working again!

Adalo Rock :muscle: :sunglasses:

Thanks Patrick , Victor , Jessi and Daniel for providing support here! Really Appreciated!

2 Likes

Thank you Adalo for the quick support on this! you guys rock!

2 Likes