API to Billomat


I am trying to create an interface to billomat, but fail because of the results key. Does anyone have any idea what this looks like?

Thanks, Dennis

Can you add a screenshot of your test call json result please. The error probably means that the response is json but not standard format so you will need to define the key that the result is nested in. This can be identified from the test response json result.

Thanks for your feedback.
Attached you can find the result.result

You key is client. This is what you need to enter under results key in step 2 of setting up the API

unfortunately I get the same error message with the same responseresp

You tried with “client” key as singular?

Here is my example: My key is records.

with key:

I’ve tried both, but always get the same error message. attached the whole response

try with client-property-value, however in my opinion Client should work. I wonder if the error comes because you are receiving more that 1 object array within the same response. Also can you try refreshing your screen / setting up a new custom action from the beginning. Occasionally that helped me. I still believe that “client” is your key, but you can also try it with client-property-value

@DSA i guess your problem is to do with API Design based on the documentation.

Try adding the Header
Accept: application/json

And see if it works.

1 Like

I tried everything but nothing worked. client, clients, record, records, …

attached you will find the setup that i am using. maybe another mistake?


Don’t put any results key and give it a try. If that doesn’t work, you may want to contact the Billomat Team for assistance


curl -H ‘X-BillomatApiKey: {apischluessel}’

Your base url shouldn’t contain the api key, it should only be passed in header. Noticed you have the api key url in all the places.

  1. Base url as above
  2. Header with api key as above
  3. Header accept application/json

And no results key in get all. It should most likely work.

If it doesn’t, contact their tech team.