Can’t copy/paste screens

Weird situation. Normally I can copy a screen from one app and paste it into another. Normally I can also copy/paste other elements too, like groups, lists, and text boxes.

But in this one situation, I can’t.

I cloned an app from another person. I can edit the cloned app in all other ways. But when I try to copy/paste, nothing happens. I’ve tried opening both apps in different tabs, and in different windows. I’ve even tried opening each app in different browsers. No luck.

I’m using Google Chrome, but I’m also trying with Safari. My device is a MacBook Pro.

I CAN still copy/paste from other apps in my Adalo inventory. Just not this particular one.

Any ideas?

Hi Michael,

I guess you are trying to copy a screen of the app that I created here! I also faced the same issue and I can copy only the Login screen and Add Items screen! I cannot copy the Checkout screen and Returns screen!

Seems like I found the issue! I tried to remove the List in the checkout screen and then copy the screen and paste it and wow it worked! Then I removed the list and made that whole group as a list again but no luck!

Then I cut them down to two groups and they both are two lists and then I grouped that two lists and made a group and FINALLY IT WORKED! :scream:

I think the issue maybe the grouping! You need to clone the app again to check this!

Thank you

Greetings @dilon_perera

are you saying you removed the binding for components and you were able to copy/paste? I am having the same issue with copying screens.

I guess there was a problem in grouping. Not sure. Once I ungroup and make that short it worked!

Is it possible to show it on a video? Or you can send me a DM your App URL and which screen you can’t copy and I’ll try it on my end. If the same happens the best is to Submit a Support Ticket


I will DM you, but I suspect this might need a ticket as you should not have to ungroup I suspect…. But I could be wrong

Greetings… I am still having the same issue. When I go to copy a screen from one project to another, I am not able to copy all screens. It looks like I can only copy over “simple” screens that have inputs and not screens with lists or custom lists.

I think I found the issue! This happens if you try to copy a screen that has a custom list! If you group the list by clicking the three dots > make a group and then try to copy no problem! @MikesClub now I see that in the app that I built after grouping the list, copying work! But before, the list was not grouped and you cannot copy the screen! Looks like a bug! Will report to Adalo!


Thank you so much…

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.