Can't bring multiselect dropdown field to front

I’m using a multiselect component along with a custom list and nothing I do brings the dropdown in front of the list.

I’ve tried bring to front, bring forward, I’ve tried removing and re-adding.
This is really frustrating and I’ve seen multiple unresolved threads on the topic.

Does anyone know how to work around this?

Did you try fixing the multi select dropdown to the top?

seems no such option. tried fixing list to bottom but that just broke the page.

Seems that’s about vertical position, not z position, unless I’m mistaken.

At this point, I’m convinced that the component is buggy, because it goes behind all other items no matter how I try to bring to front.

Make font pinned to the top, I think that could help!

do you mean anchored? if so that seems to be about y, not z position as per above. Also not available on that component.

Are you saying something else? (I hope so! but didn’t understand, can you explain it again?)

When you pin to the top the texts stays at the top, so it goes forward from the list.