Can't update some database fields

As I try to update the fields in some database entries through the Database Collections tab, I’m getting an Internal Server Error. This mostly seems to happen on databases that didn’t/don’t have a Relationship field with users. Reloading doesn’t change anything, and it’s happening for all members of the team.

Any idea what is happening and if/how I can fix it? It’s hampering my team’s ability to implement certain functionality.

Can you send a screenshot where that’s happening?

May be adjacent, but our images are not showing on our user app. Additionally, images are not loading on the Adalo database side nor can we upload new ones. This happened recently/suddenly.

When I went to view an image, there was a 503 error during the auto-compression of the image.

How did you first updated the record?

One of my teammates created the record, but it happens when I try to create a new record too.
My process is:

Database (left menu) → Test Types (collection) → 2 Records → Add Test Type → fill in fields → press Save → Internal Server Error

I tried creating an entirely new database and adding an entry and that worked; then I deleted and recreated the field I was trying to edit (I was never able to add any entries to it anyway) and it works now.


If you try to create it from in-app do you get error?

I did when it was broken

I don’t really what is the problem that’s weird, and from here i can do nothing. Sorry