Custom domain not working

Is anyone else having this issue?
The custom domain link stopped working (This site can’t be reached). I had no issues with the test connection when setting up the domain. It worked initially but stopped working since yesterday.

If it makes a difference, I am using hover as my domain name provider.

Thanks and Regards

What is the url? I cannot help without more details so that I can look in to it.

Hi Colin, thanks for your reply. Wasnt sure if I was to put the details here or on some help email / contact.
The website is
I tried it again today and it does not seem stable, ie it only works sometimes.
As I am writing this message, it is not working. There is no issue with my internet connection.


Can you share a screenshot of how you set up this domain inside Adalo and also within your registrar (dns)?

Hi Colin, I bought a .net domain and tried but still no luck! Below are the screenshots from my adalo screen and domain provider

Hi @suresh,

CNAME for is correct, so you need to set up it in Adalo:

Hi Victor, I’ve changed it back to and everything is working fine now.
Thank you for your reply!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.