Custom Domain/DNS Issue

Not able to set up the custom domain. Create the DNS record a while ago, but just get the infinite wait. Any ideas?

be a problem with the CNAME I have godaddy so instead of including the entire domain include only the sub domain prefix.
use app instead of

1 Like

Thanks @tan97 tried that already, didn’t work.

Which provider your domain is registered?

Godaddy is the registrar I use

Go to your DNS Management & create a redirect to (via your domain with help CNAME).

For more deep tutorial please follow the Adalo Help center

@AJAY feel free to share a screenshot of your dns setup in godaddy.

1 Like

This varies based on provider, but probably the answer is to have the value in the @ column just be “app” instead of

Perfect. Thanks @Ben

I would suggest adding where it says “Name: (or just app)”

I’m having the same issue. The testing connection process do not finish. I tried with the cname considering the full structure and only app. I checked my domain with a dns checker and received that is working since last week, but I can’t finish the process in the Adalo setting section.

Thanks for your help!

My solution was to only use ‘app’ not

ok, I tried that without results last week.

@Ben could you help me? I understand that this is some kind of bug.

I would suggest posting a image of your DNS records so Ben can better help.


For your DNS here’s how I have mine setup:

Then once your DNS passes, under publish > PWA select your domain and hit save.
2020-04-27 21_13_28-28-

I hope that helps you. Keep all of us posted.

Hi @bakerofideas! I created the same cname record without results. If I check my dns url with, the results is:

Do you obtain the same result?

When I tried the process in the Adalo site, the test connection process keeps running indefinitely.

No. It should come back as only

1 Like

@Neker Can you share a screenshot of your dns setup?

Hi @Ben attached the screenshot requested. I tried hr only also.

This can vary by DNS provider, but I believe what you need to put for the Alias is just “hr” and not “”