Export As PDF - API Issues

Hello all, again.

So I am trying to get this PDF Generator plugins to work (or if there is a better way, please). But for some reason, I used pdfgeneratorapi.com and got this:

  1. API Key
  2. API Secret Key
  3. Workspace identifier
  4. Template ID (I wrote the HTML and CSS for it already)
  5. JSON Payload

What am I doing wrong here? When I click Generate, it just spins a loading wheel, then stops.
I have everything required under the API/JSON etc., keys and what not.

Below are some screenshots:

Update 1: When I click generate it leads me here now.

Hello! Tanel, founder of PDF Generator API here! The Button External Link value must be the result of the PDF Generator API task. Use the Magic Text button to map PDF Generator API > PDF Output with the button action.

We have prepared a step-by-step tutorial for the component: How to integrate with Adalo? | PDF Generator API


Edit - Here is a sharable link to our app right now: Task Manager Plus

Thank you very much for responding! And thank you for creating this tool. I am so used to writing code, and I am still training on Adalo, Bubble, and others right now.

So, I have a PDF Generator 2 (named it 2 for some reason, I think I had a first one I didn’t delete; I will check), and I linked it to PDF Output, and I get a spinning wheel that finishes in a second or two:

PDF Output:

And I have the JSON payload, but I got this from here:

This is just a training app, and I will regenerate the keys if I shouldn’t have them publically here as this will not hit any app store.

I will go over the tutorial you sent me again, and give it another shot. But it seems I have everything where it should be. I am missing something, though.

Thank you so much for responding so swiftly and generously, by the way, sir.

So, I changed my workplace identifier to my email, as you said. I will head back over to your website and see what else I can do because I use Firefox Developer Edition for the extra tools, and it seems to be going here:

Here is where I attempt to create a JWT, but I get this error:

Overall, after using JSON Web Tokens - jwt.io and your website, I am still failing to get it to work, and it is due tomorrow at 9:00 am PST, so I am getting worried. What am I failing at?

Now, I verified my JSON Web Token here:

I have PDF Generator API as PDF Output:

I seem to have everything right. What am I missing? Anyone?

I feel like I have done everything to get this to work. I was thinking if I did something like this it might work, but it still doesn’t:

I am completely lost at this point. If you or anyone could figure this out I cloned the app and think link is still the same above these posts.

drop you a pm, add me to your app I can help to take a look


Thank you! I will check it now.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.