Geolocation - not working on devices

Hi there, wondering if someone could help me figure out a bizarre problem I am having with the new Geolocation update. I have been successful (with the help of a friend Dilon!) to get Geolocation up and running on my application; however, for some reason, on my two personal devices i do not get the “request for permission of location” from my own app. I tried logging out completely and going back in again. I cant figure it out, so it is becoming very difficult to test my new features without being able to share it with myself or preview it.

Does anyone have any suggestions as to why this is only happening on my 2 personal devices that i have been using relentlessly over the last 5 months on Adalo? Is there an easy fix for this that I am just not seeing? (note, i sent to my wife and it works perfectly on her devises)

Need some help desperately!!

problem was figured out. Settings deep in google BROWSER settings, if turned to “never” will not show you any push notifications for location requests.

1 Like

You can add a button to your app, then one of the options is permission location, this should force user to get permission question, let me know if it works, as have not had a chance to try it yet.

thanks for that. I had that, but I was not even getting the notification when the button was clicked. I couldnt figure out why that was only on my devices (worked on my partners) and then when i went into my google settings found that when it is checked off as “never”, even if you have a push notification sent to you, you will not get the request to turn location on. That is unique to browser settings and not device settings. Not sure why google has that set up that way, frustrating for anyone who only wants to allow “sometimes”…

said differently, push notifications dont work in the share/preview environments (browser vs app) for anyone who has it checked off as geolocation “never” in their google settings. You wont even get a notification

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.