How Do You Remove Custom Component from Adalo App


I’m still having issues with Adalo not allowing me to upload a new build of my app onto TestFlight because of a custom component as it’s giving me an error of “Error Packaging of Application.”

Does anyone know how to remove this custom component from the “Private” folder in the settings of Adalo? I tried to no avail.

Any help would be great. I’m attaching a screenshot.

I recommend contacting Adalo support.

I’ve done that. We created two tickets. Emailed Adalo support for the past two weeks. Still hadn’t received any responses from them. Adalo Support is taking way too long to respond to our support tickets. It’s really unacceptable.

This component is still somewhere inside your app, it doesn’t matte if it’s in your private section. Make sure to check every screen for it.

Next to remove it, you need to go to the profile section top right corner > developers > scroll to see it > remove from and select your team.

If not found, this mean a developer has added it to your team, you need to contact him

I did that. Apparently, just the other day, the component was removed from my app but today it’s back again. I had to sign into the lead developer’s account to remove it from my team and removed them from my team altogether. The developer uploaded the component onto their library but added it to my team. Now, the component is no longer in the private library but it is still giving me the same error of “Error Packaging Applications,” and when I search for the error it tells me “Error Retrieving File.” And when I try to publish a new build from Adalo I get a message saying that “We weren’t able to verify your App Store Connect Credentials.” even after it asks me for a two-step vefication code but it goes ahead and sends the build to Apple anyways but then ends up failing.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.