How to View Errors from a Custom Action?

I’ve successfully created a custom action with the sample inputs…but when I’m using the same action in my app using info in my collections using magic text it is not working. I’m sure the api my custom action is sending the request to is sending back the error code that I’ve generated but I don’t know how to get that information to help troubleshoot. Is there a way or best practice of setting up some kind of “errorlog” collection that I would be able to create records every time I get an error…but the only fields I get back from my action are the fields from a successful action…I’m stuck not sure how to get then info if my action generated an error. Any help or direction is appreciated.

Hi @pkmiller,

This could be a nice feature like Glide is currently building!

You can share this here :

But in the meantime you can use the Network tab in Developer tools! ( What are browser developer tools? - Learn web development | MDN )

And also what’s the API you are using and what doesn’t work?

Thank you

Hi @pkmiller,

You can see a part of what is happening in Developer Console.
In Google Chrome, you need to open the “Network” tab. There you need to look for “execute” calls. You will see the payload which is being sent to custom action backend server, and you may see some info which is returned by the 3rd party API you’re interacting with.

In my experience, most common mistake is caused by wrongly formatted JSON payload. For example, in the JSON you may be sending number values, but in Adalo custom action setup the number formatting isn’t set to “none”, leading to commas which break the payload. Usually you can see what’s happening in the console.


1 Like

Hi Victor,
Thanks for your message on this. I was not aware of the developer console on chrome and the information on the network tab until your message. I’ve spent some time studying it and running the preview of my app with that window open. After some testing and revewing the “response” tab on the “execute” lines I was able to solve one issue but I’m still not getting an output. My custom action sends several fields to the api. After one by one replacing each field with static info I was able to pinpoint the issue is with an image URL that I’m sending to the api. When I hard code the image url directly into that section of my custom action it works. but when I change it from a full url to a dynamic field pulling from the collection it doesn’t work. When I go look at the record in the collection it is there with the url present and it’s the exact same url text as when I pasted it in directly to the action. Any idea why it would work when put in directly and not when put in dynamicaly from a collection record? from the edit custom action pages with sample inputs it always works fine so that part hasn’t been useful for troubleshooting.

For referrence the api I’m using is from which is an image generation api. This page has the endpoint I’m calling: Generate image - Abyssale Developer Hub{templateId}/generate

It also has error codes at the bottom. I’m getting a 400 error saying “invalid parameters”. For reference here’s also what I think is the relevant portion of the json I’m sending in my custom action.


Any suggestions are appreciated. I feel like your prior message about the network tab opened up a whole new world for me :slight_smile: so I’m appreciative regardless.

Hi Preston,

I tried the API and here’s what I get : Generate Image - Abyssale API.mp4 - Google Drive

Could you share a full video about your custom action setup? If you don’t like to show it in public you can send it to me privately!

Thank you

Hi Preston @pkmiller,

I wonder what is “d-props-house” - I don’t see it in the API docs :slight_smile:


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.