Input field not working correctly

The input field in my PWA is not working properly. It will not pass the data in the field to the database unless the user first closes the keyboard by pressing “done” on the iPhone and then presses send. This is happening on my login/signup screens and chat screens and is a pretty glaring bug. I’ve reached out to support already but haven’t heard back on any fixes yet. Please see the video attached below for reference and if anyone knows a workaround for this please let me know.

I can also confirm that this bug occurs with forms & text input fields for both native PWA and desktop web apps accessed via iPhone 11

Hi Kevin,

This looks like a bug. Please submit a support ticket. :slight_smile:

Hey James! I submitted a support ticket about two weeks ago and got an initial response that they were looking into it but haven’t heard back since then. As you can imagine, not being able to correctly enter text and have it submitted to a database for a PWA (using forms or text inputs) on the iPhone is a pretty critical bug and really doesn’t allow me to progress further until it is solved. I hope it can get solved soon.

Found a workaround to this bug in case anyone else encounters it. Instead of creating a message (for example) in one action, you’ll have to make three separate actions. One to create a blank message, another to update it with the input text, and a third to clear the input field.

What I’ve found is that if I type in the text too fast (before the little blue ticker in the input field pulses) then it doesn’t record the data in the field. That is what’s causing the issue so hopefully that helps solve the bug.
@Colin @James_App_Maker - in reference to the bug ticket I submitted, if you could forward that info to your engineers or whomever this would help that would be great

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.