BUG: Textbox/Input box won't clear

I have a simple app that 's been bugging in the last couple of days now, it seems that it has not been fix.

this occur this week only my app is functioning well before this happened.

^ You will see that I have a input box on the left and a custom button on the right which has a trigger of change value of input box to empty.

but as you can see it won’t clear the input box but it clears the data of the custom list where I connected it.

not sure what’s causing this error I tried creating a new app and it seems that it is a bug coz the new app also has the same issue
you will see in the parameters that I have set the input box to clear when the button is clicked.

I have reported this as well but no response as of the moment, anyone can confirm having the same issue?


I’ve also noticed that the ‘change input value’ to empty stopped working

I’m also having the same issue.
Earlier the input field would clear automatically after submitting (in chat feature) - as would be expected and wanted.
Then that stopped working. I tried this workaround, but now also this stopped working.

1 Like

I am also having the same issue but what I’ve realised that if the clear field function is on the back button it clears the field and moves the page but if it’s on the same page then it does not clear, I have tried on the messages as well as the search to clear the field and nothing happens. This is only happening in the PWA as that is live but the apps in the app stores are fine they are still functioning well.

Hope this gets fixed soon.

but do the apps in the store have a recent build since this started happening, or do they have an older build?

Do you have a screenshot how you manage to do the workaround?

I have native ios/android builds in testing phase and they also have this bug

They are older builds, if you export now, the issue will carry over to the apps

I have no workaround for this, it’s a bug which Adalo may be fixing as we speak.

Hey @afonso @StevenU @Kasimjh @Biboy,

This is a known bug that Adalo is currently working on & should be fixed this week. :slight_smile:


Hi @James_App_Maker

Do you know if there’s any feedback on this?


1 Like

For me the problem is still here :frowning:

Yes I am experiencing this already for 2 weeks until now not yet fixed :frowning:

1 Like

@afonso @StevenU @Victor @Biboy @Kasimjh

This issue has been fixed. For the fix to take effect, you need to push a new build.


Hi @James_App_Maker

Should the fix be visible in the previewer?
In my case, it isn’t (neither does the input clear once a message is sent, neither when I add the change input value action).

Awesome, thanks for the update!

Seems to be working for me. Did you try removing the action/input and re-add it & test again?

If that doesn’t help, please submit a support ticket. (if you already submitted one, update it with more info)

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.