IOS Emulator for testing components

Hello guys,

I’m working on building a component for Adalo. I tried to test it on IOS emulator. I did everything according to Testing | Adalo and Using the Adalo Mobile Development Toolkit to Test Your Components - YouTube

However when I’m on step of launching xcode file and run app → I see “Build failed” + lots of (like 112) different messages on bugs and etc.

What can cause the problem?

Best regards,

Hi Glib,

Did you run yarn start?


That’s what is happening - here is video: Screen Recording 2021-08-25 at 17.52.44
I’m checking is it some software compatibility issues as I’m working on M1 Macbook.

Did you get any errors when the library compiled during development? is the component working as expected in the editor?

I’m just trying to launch emulator at this moment. The plugin seems to work.
The problem is on step of compilation of app in xcode.

There seems to be a problem with android emulator as well with M1 Macbook :frowning:
It runs API 29+ emulator on ARM well but not 28 (it is only available of x86 version :()

There are errors when I run API 29 emulator + running npx react-native run-android command :frowning:

Ok so the summary is that is due to using Mac on M1 chip. The same problems goes to android studio, where API 28 is required when in M1 you can only launch API 29+

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.