List's Maximum Number of Items working incorrectly, showing too few

Good evening all, When I create a list asking for a list to display a maximum of 5 items, none show up. When I change it to a maximum of 11 items, 6 show up. When I change it again to a maximum of 16, 7 show up. (As you can see, it’s not even a simple {maximum-x} since when I ask for 11 I get 11-6=5 but when I ask for 16, I get 16-9=7)

I’m not sure what to do with this. The list has some very (very) long formulas in the actions that are a chore to replicate, so I would like to avoid having to recreate the list and I’m hoping there’s just something obvious, but I saw this happen on my first day of using Adalo with a cloned template as well and thought I must have done something unexpected to it and so I deleted the list and recreated a new one. Now I’m thinking maybe it’s a bug? If not, anyone know what I might be doing wrong?

I’ve searched the forums and not found much about it, which suggests it’s me, but I know that when people have trouble with lists, they seem to just delete them and re-create them, so maybe everyone’s just defaulted to turning it on and off again and that works and it never ends up in the forum?

In any case, HALP!

Yup, it was me.

(I tried deleting this topic but no-go so my shame must remain displayed here for all to see.)

It looks like when I restricted it to just the logged in user’s records, it worked fine. I’m not sure what I’ve got wrong elsewhere such that it’ll only show the logged in users, but I suspect this is something that I’ve done and not a bug. Hopefully that will help someone else if they end up in the same spot somehow. Sorry to not have a clearer idea of what’s causing the incompatibility between bits of data.

1 Like