Page unresponsive on update

When I click on a field in update record, used to popup add, remove items for the selection even after some delay. but today I’m getting page unresponsive message, if I click on wait, after sometimes getting offline msg and action terminated. anyone of you facing this issue, Adalo team please help.

Hi team adalo, help me on this…I’m stuck

Hi @Reyaas,

In my experience, one of the possible reasons for this could be low speed of internet connection / high memory load on your PC / high CPU load on your PC. For example, when I had a lot of various tabs open in a browser, the app builder interface started to work slower.

Also, clearing cache at the browser might help. You may try to use other browser as well.

If the problem persists then you could submit a support ticket here: https://info.adalo.com/submit-a-support-ticket

Best regards, Victor.

1 Like

Thx Victor, still the same, I’ve post the ticket. I don’t see any performance issue in my pc and not opened many tabs in browser.

This is a performance issue with how the browser is handlign the request to populate the dropdown menu with all the appropriate relationship choices.

We have noticed that this only seems to happen with apps that have a dozen or more collections with multiples of that in terms of many to many relationships between each collection.

This is something that is being worked on our end to see how we can improve this as part of our performance. Unfortunately due to the complicated nature of these things, this is not going to be a quick fix and may be months before we are able to find a suitable replacement for this functionality.

@Colin, really I feel it is DB server issue, I’ve about 25 collections and lots of relationships, building quite complex app and expecting about 200,000 users in 1st year. Can Adalo handle this load?

This issue is a frontend issue and definitely not a backend one.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.