Please help, my webview loading but not responding to my button clicked

I’ve been finding a work around on how to integrate payment on my app and i discovered a payment gateway in my country which has a simple inline javascript script that can collect user info from URL and proceed to their payment page. I used the adalo webview and attached URL with parameters to pass user info which loads on webview successfully but on clicked on the payment button nothing happen instead of loading payment page.

Here is link to test page on my server


Hi Mark,

I have added the URL to a test page with webview and the button works for me…

When you click the button does anything happen at all?

When I clicked the button nothing happened, please how did you do it.

Thanks for your response, which gives me the hope of the possibility of achieving my goal with Adalo. please i will like to know what exactly you did to make it work, cause when i click the payment button nothing happens.


I added the link in a webview and it just worked

That was exactly what I did, yet nothing happen when I click the payment button. could it be a Bug?

It could be your broswer, do you have the most up to date version? Have you tried in a different browser?

I just tried using all my browsers, same result. Here is a shared link follomebet

please share yours so i can confirm

It looks like you have not copied the link in correctly, you may have a space at the end or other characters that should not be there.


Update the URL to remove these characters and it will work.


1 Like

Oh yeah, thanks it finally worked

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.