Troubles with custom component development

Hello! I was trying to create my custom component, to add sharing through apps feature. I found react library, called “react native share”, and I hope with it I can implement this feature. But when I import needed elements, adalo component breaks, and for no apparent reason.
I recorded video with this issue, can somebody tell me, where is the problem?

Hi David,

Welcome to the Community! :partying_face:

There is already a built in option in Adalo for sharing? Does it not fit your standards for your app?

Hello! Thanks for your reply. Native sharing option is very weak in adalo. It can share only text, but I want to share images, videos, and maybe multiple content. I saw this option in suggestions, but it doesn’t seem to be implemented soon in adalo. So I decided to create my own component directly for my needs, but that library makes something strange with adalo, even though it compiles fine. Problem is only with this library, maybe it’s a bug? Library is very popular, and a lot of people use it in their custom react native apps, I think problem is in adalo, can you find out that issue and fix it?

Just figured out the issue.

It’s because your not using “url_link” and “description” so it’s returning undefined, try removing those and it should work. Also you need to add the share feature into the app, it won’t work just from the import.

No, unfortunately it doesn’t work. Problem is only with this library, I tried installing another react libraries and the are working.
I know, that it won’t work only from import :grinning:
Now I am just trying to run this only with the import, and it still doesn’t work.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.