Actions break after some time

From time to time, actions stop working. This can be any kind of action e.g link to another screen, create a new database, and so on. They suddenly stop working, the only solution is to delete the action and create it again. This is so annoying. Am I the only one experiencing this? Does anyone have a solution?

Hi @SBK,

This is weird - usually actions don’t break without a reason.
What do you see in the browser developer tools console? Are there any errors for “broken” action?

Did you try to submit a ticket describing the problem (and showing non-working action which worked before)?

Best regards, Victor.

I did not have the best experience with Adalo support so far. I will try my chances again, they usually dismiss the problem saying there is nothing they can do. Here is the screenshot. It happened again few minutes ago.

If I delete and re-add the action, it works. But it gets broken after a day or two.

I fixed the actions by deleting and re-adding them. But I cannot be doing this all the time… This is the console log after I fixed it.

Hey @SBK,

Definitely this is not a correct behaviour - you’re 100% correct that you can’t delete and recreate actions every time.
I don’t see anything specific in the logs at a glance - the errors are related to launchdarkly and sentry, which are technical services used by Adalo to monitor the platform behaviour and catch errors. It seems you have some kind of firewall or antivirus which is blocking these connections btw. But I don’t believe this should be related to app action failure.

What I’ve noticed is that the action is conditional. Are you sure that condition is met every time - did you check that in the database?
Also did you try removing condition (to isolate the issue and see if it’s related or not)?
Also it could be interesting to have a look at Network log at the time you click on working and non-working action. As this is a webview there should be some attempt to open the external resource with this action.

Just in case: I assume that you’ve tested the non-working actions from different devices and browsers (including private browsing mode) and you’re sure this is not related to an exact browser/device configuration.

Adalo CX team has much more capabilities than we do so it is still worthwhile to submit a ticket.


I have tested it with multiple PCs and phones (including my clients). I do not change any database entries. I just fix the action, test it to see if it’s working, wait a day and it’s broken again. This is not the only action, it happens with non-conditional actions as well. This was just an example.

@SBK well I can say that this is definitely not the behaviour which is expected from the app. I have had an experience of working with 100s of apps in Adalo and if actions’ breaking with no reason was a common case I would have noticed it already :slight_smile:

Thinking logically: you are showing the problem with External Link action. As you’ve showed the conditional action, there was a chance that the condition was incorrect, therefore action wasn’t executing. With your recent comment, it turns out that the problem exists with non-conditional actions as well.
Then we can conclude that it might be something wrong with External Link actions using In-App browser. One of the options is this could be related to a Website URL being interpreted incorrectly - maybe there is some hint in Network console for that.
Another possibility is that the database entries are different (I’m not saying you are changing them, but usually database entries could be changed over time by users).

Or you have other actions (like update record, create record, etc.) breaking too? This is a completely different story then.

Also as you can imagine it is quite difficult to diagnose the issue based on messages and screenshots, and your app is locked for new users signup so there is no way to see a non-working and working cases.
If you’re willing to you can create a separate screen for testing, put an action there (NON conditional) and let me know when it’s broken so I could have a look (of course I’ll need an access to it) - feel free to DM.


Should I put a link to my PayPal account? I’m not going to debug an app I’m already paying premium prices for free.

Jokes aside, I submitted a support ticket, let’s see what they’re going to say first.

Dear Serkan @SBK,

Please let me clear things up here.

I was trying to help you in solving your issue, in my personal free time. I do that quite frequently on this forum (with over 2000 replies posted in last 3 years), and I am not requiring link to PayPal account for my every reply.
I do provide paid consulting to my customers but requiring payment for advices on the forum is not the way I earn money.

The problem is complex and it was interesting for me to investigate. Unfortunately the information you provide is scarce and incomplete and it is quite difficult to understand what’s happening in your app. Moreover there is no “non-working” example of the issue.
Therefore I suggested to create a screen to debug this problem and send me the link to it in DM - as you might not be comfortable sharing it publicly (given the fact that your app is locked for new users).

Just in case, DM does not always mean that someone wants to sell their services.

In this particular case unfortunately I won’t be able to help. In my opinion contacting support would be a good option.

Wishing you all the best.


1 Like

Kudos to you Victor! I’m aware that you are just trying to help, my comment is not directed towards you in particular. As a paying customer, I do not like the idea that I have to debug the software myself. I expect the product I’m paying monthly to be functional.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.