Adalo API // Unauthorized error - Certificate has expired warning

I am trying to test the Adalo API using postman but am getting a 401 “Unauthorized” error. Am using the the Bearer API key generated in the API docs. Any ideas what’s happening here?

I’m also getting a “Warning: Certificate has expired” message.

Tried re-generating the API key and sending the request again, but same error.

Just tested in Postman, was able to get all users.

Has this worked previously for you or is this your first time trying the call?

Looks like the API status is green -

First time for me, though it seems pretty straightforward. I’m just copying what’s in the API docs.

I have a custom domain set. Could this be a possible cause?

Nope. Shouldn’t be that. Can you share a pic of your postman records (black out the keys, please).

No problem - attached. Thanks for taking a look. What have I screwed up?

Update: tested access to the API endpoint via another service (Parabola) and it worked fine, so it’s clearly something to do with my request. Unfortunately Parabola hides both the request and response… :cry:

OK - got this working. I took all the headers out of the string and instead just included the bearer token under authorization and problem solved.

Thanks again for checking on this!

1 Like

Yep, that was going to be my suggestion!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.