Adalo doesn't recognise (pull) numbers from external AirTable collection

Noticed multiple instances when in some cases Adalo successfully pulls a number from an external AirTable collection as a magic text and in some cases (even though the setup is the same) - it doesn’t.

Investigation Steps & Results:
• Noticed Adalo successfully pulls “Count” or “Number” field values from AirTable but does not pull values of a “Rollup” field
•Tried solving by pushing the Rollup value into a “Formula” field and using this value in Adalo. Didn’t help.
• Then tried processing the value in various ways within formula field (with ROUND(), INT(), to a text value with CONCATENATE() & LEFT() and then back to a numeric value with ABS() etc. etc.). Nothing helps.

Why? What’s happening here? Is this a BUG?

I understand Adalo may not manage to pull number from a Rollup as it’s an array… but I convert that array function result into a value within a formula field. Why this doesn’t help?

Thought that Adalo may also struggle pulling a number from a “Formula” field… but this should not be the case as it successfully pulls numbers from “Formula” fields in other cases.

I am able to pull in Rollup fields okay. The rollup is actually just an integer to the API. But I know strange stuff does happen depending on your setup. Could you share a little more info about your setup? Also, a few things to try:

Make sure you have a least one row of data with all fields filled in. Adalo ignores JSON keys that are null when initially setting up an API.
Try adjusting your Rollup field to be a simple formula like SUM() to see if that improves the results.

1 Like

Thanks for help, @pfordmedia , as always. Really appreciate this.

So I managed to finally get 3/4 components to work (even though it seems I didn’t do anything differently) but 1/4 is still persistently refusing to show the value.

Here is a LOOM VIDEO with all details about the setup.

1 Like

Thanks for the video that really helps. A few things here:

The column names in Airtable cannot contain a period as Adalo interprets this as dot notation in the JSON results. Try removing the period and see if that helps. This applies to all the columns

For the formula field, see if you can set the format of the formula results to decimal and then specify the decimal precision to match the numbers you are displaying. Sometimes decimals do not pull in if the precision is not set correctly. Also sometimes formulas can have trouble determining the data type which may be happening in this case.

1 Like

THANK YOU, @pfordmedia .

This helped. In this last case that was not working it was actually about the decimal precision in the formatting (didn’t know that this matters while transferring the data).

Marking your response as a solution.

1 Like