Android build APK is returning an error API level 28

My app is already in the google play store. Upon trying to upload an updated version APK, I received this message:

“When you upload an APK, it needs to meet Google Play’s target API level requirements. Both new apps and app updates must target at least Android 9 (API level 28).”

Does anyone know what should be done here?

3 Likes

Yes, I am having the same issue. Google required the Level 29 on August 3rd and it looks like the build tool on Adalo outputs the file with the previous version

For first time apps to the PlayStore the API Level 29 is required as of August 3, for updating apps the update must be complete by Nov. This update has taken longer than we anticipated as it requires updating a few other things and we want to thoroughly test so that it’s a smooth process for all users. We hope to have this complete today. If you are submitting and update app it should allow you to continue moving forward.

2 Likes

Is there anyway Adalo can announce somewhere when this is fixed?

I am having the same issue.

when this will be fixed? is there going to be an announcement?

1 Like

Any update??

I am still waiting for the fix to publish my app to google play.

Same here! This is a pretty core functionality of adalo

Please add your upvote to this bug report and you will be notified when the issue has been fixed.

https://ideas.adalo.com/bugs/p/api-level-28-error-on-google-play

1 Like

This has now been fixed. Please create a new build to solve this for your app.

1 Like

WORKED!!
Thanks a lot!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.