Audio Component Not Working

Is anyone else’s audio component not working? It has worked perfectly for me for the past couple of weeks but this morning I tried it out and it does not work… it seems like it went back to the old version where once you click one track it will not update the file when you click on the next one…

To further explain:

I tap track 1 which has a run time of 5:00

  • When I exit that track and try to select another, the audio itself does not change. Basically, the component does not reset anymore when I click between screens as it has for the past couple of months.

Additionally I have meetings with multiple colleges this week regarding adding my app as a benefit to their students which is time sensitive… Having to reschedule those meetings due to a bug like this is not ideal and will result in a loss of money. If anyone has ANY idea on how to fix this issue please let me know!!

I’ve checked all of the files and external database permissions and they all work perfectly fine, it’s just transfering screens that’s the problem… Basically I can only tap on one track, if i want to change the track I have to completely shut down the app and re open it.

Hi @tmurray19 I have been working for the past 6 hours with no issues with the audio player and I have mine set up with list which updates the track on the same page. I’ve been able to go between different tracks on the same screen and change screens to a different album and do the same there.

Are you working with it in testflight or the adalo previewer? It works fine in adalos previewer and safari but does not work in the live apps. For me. I’ve been working with it for 2 years and for the past 8 months it has been perfect, not sure whats going wrong.

I think it is going in and out - I had everything working perfectly this morning and now it isn’t updating the track.

So weird right? There must be a bug in the code. Also, i noticed that it works perfectly on android devices which just adds to the stress.

Have you been able to talk to support about this?

I’ve submitted a ticket. Interesting that it works on android. Hopefully we get some answers soon!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.