Bug with Follow/Unfollow buttons and followers/following screens

Hi! I’ve set up my follow/unfollow buttons according to this tutorial link however whenever follow someone, the buttons don’t switch from the follow one to the unfollow and also the current users followers doesn’t update.ezgif-7-c701afbbbb5e please let me know if you have a solution! thanks

@pfordmedia any tips on this since you probably know better :grinning:

Hi @athie,

I would advise to check the following:

  • that you correctly update Current User reg. Followers (adding logged in user)
  • that you correctly update Logged in User reg. Following (adding current user)
  • that you have correct visibility rules set
    Also you could check the database collection - if something changes there for the user record.

@Victor i’ve already done so but still i havent been able to find something

Hi @athie,

There was a similar thread recently, see Very weird (or bug?) behaviour with 2 types of "follow" relationships

Not sure if @jnestour found the root cause of the problem.

I’ve mad a POC with regular buttons, for me it worked perfectly. What I could suggest - is that you recreate the follow/unfollow buttons from scratch, and see if it works.

Otherwise it is difficult to find the cause of the problem without looking at the app itself.

1 Like

@Victor I did that however when i follow someone the buttons still dont switch…

Is anything changing in the database when you follow someone? If so, it’s probably visibility related. If not, then it’s action related.

1 Like

nothing changes in the database:/ what should i correct??

Double check the actions you have made to create or update the records. Post a screenshot here of those actions so we can further help if you require it.

thanks @Colin

1 Like

That all looks fine to me :confused: can you give me a link to your app. You can post it here or DM me directly.

thanks @Colin just sent it to u:)

@athie Your logic is correct but you have the wrong variables plugged in. You’re using “Current User” - this needs to be “Logged In User”

@iron49man thanks but i think ive trired it already

Hi Athie, I’m strugglign to troubleshoot the issue as there seem to be a few other errors in your app that is confusing me a bit.

When I view a profile I’m not seeing the user for example:

So I am not sure who this user was that I was meant to be following.

If I look at the console of Google with the call I make when clicking the button, I get a 500 error as it could not find the “current user”

thanks for letting me know @Colin colin i tried to send u the link again which will hopefully work:)

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.