Can't create record thru Make APP

Hey Guys. I am using the Make app and trying to create a record in one of my databases that just keeps coming back with 400 errors with no error message. I am able to create records with other databases just not this one. I can however perform a get request to the same database that fails on the create record using the same connection in MAKE

This is a user database with fields of first name, last name, username, password, etc… Tried leaving out specific fields but nothing worked.

I am able to update an existing record in the database and the rest of the endpoints except create.
All other databases create endpoints work.

Any advice would be appreciated. Thanks

If it’s a call to the Adalo API call then it should be straightforward, so far as I know all Permissions settings are overridden with the API call.

I’ll try on one of mine and see what result I get.

I have tested and successfully created a user.

Is it because your user already exists?

Hey Rozza I am able to create records on 2 other databases but this one strangely cannot. I can update a record or list them but continue to get a 400 error when trying to create. At a loss

I’ll DM you to take it further

Hey Rozza, I copied all my databases and started over and was able to get it to work but just now, after adding another database it started doing it again. Heartbreaking after just having to redo all my stuff in my API setup. I have no idea why it’s doing this but I have to figure out the exact reason to have trust in running this critical process that relies on creating users moving forward. Wish they had a number to call to figure this out.

Hey Scott,

Sorry to hear this,
I can’t really take it further without testing it. I’ve sent you a DM.

This was due to renaming the default user fields to lowercase. Spent a day and a half trying to figure this out. Would be great if they would not allow you to change what can mess things up this bad.

Also an actually message on the error would be helpful instead of just a 400
If you try and create a user with the same email 400 if you change the name of the email or password field to lower case, 400 etc.

Something like User already exist with this email etc…

Renaming default ones would be issue @scott7414 : Create user account via external form? - #7 by Victor ( post by @Victor )

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.