Chat does not work

Can anyone suggest what could be the problem with the non-loading chat? I did everything according to the instructions, but when I try to check its performance, a message flies as in the attached image. What is done wrong?

1 Like

Perhaps because of this

Service Interruption — September 18, 2022 - Info & Announcements - Adalo

Unfortunately not) The problem with databases is a separate case, with the chat I try to figure it out on my own, I run the application on two different browsers, but still I get what I get - “action could not be completed”. In the constructor itself, everything seems to be correct, all button actions are correct, but…

Hi @paulman,

Did you tried deleting the actions and adding again and testing again? Is it possible to show this behaviour and the setup from a video?

Thank you

Yes, I tried, nothing changes. In two applications where I have a chat, it does not work.

You have already logged in to the app right? If it’s ok can you send us the app link to test this on our side too?

Yes, as I already wrote, I tried to log in from two browsers and simulate correspondence, but the problem is the same

Is it possible to give me access for this app to check this? ( Click the gear icon on left and go to the app access section and add this email : )

This feature is paid and I need to get permission from my partner

Ok no problem! Can you add some screenshots of the actions as individuals and the database? If you can share a video of this behaviour and the setup that would be awesome!

That means you are on the free plan right? Can you check the storage? Is it 200 or lower than 200?

OK, done, I’ve added you to the team.

@paulman could you try again?

1 Like

Yes, sure

Yes, thank you, everything workes. May I know what was the problem so I can fix it in another application?

I don’t know why, but the chat stopped working again. I’m trying to chat with two different accounts and I’m facing the same problem

I note this for myself: I can write a message to myself, that is, I place an ad and I can write to myself, but I cannot write to another user. Obviously the problem is in some setting.

The problem was the User relationship was empty for that two records.

I’m sorry, but can I ask you to explain this point in more detail? To be honest, I don’t quite understand what the problem is.
And another additional question - is there such an option in Adalo as message notifications? Or is it a different hardware level?
Thanks in advance))

Before clicking the button to create the chatroom you have added a list that shows the ads right? The ads collection. And then once you click on a ad , that returns to the screen where the button that creates the chatroom located. And in your update actions after the create chatroom action you have one for add logged in user and one for add current ad > user ( the User relationship created on the ads collection between the users collection ). Now in your database for some records that User relationship is empty and then that error comes up because that action have nothing to do. Once you add a user there you’re good to go!

It’s better explaining this from a video but unfortunately I lost my computer for a some time period and I’m coming from my phone. It’s hard to do with the phone but can do small things. I’m really sorry for that!

I would appreciate it immensely if you could demonstrate the procedure in a video when you can. It’s hard for me to understand it in words)))