Copying text on Android (and iOS?)

Hi all,

I’d like my users to be able to copy text from within a text element (not an input). On the ‘Edit Styles’ menu, I’ve checked ‘Copyable’ so I think I should be able to copy the text. But all I get is an error like the below, when using the Android Previewer.

I tried long-press and tap.

Any ideas?

1 Like

Also, I’ve tried to copy on my Desktop webapp ‘mirror’ of my app, and have set the text to be copyable as well. Trying to copy involves the really not-normal long-clicking of the mouse - @jeremy or @Ben could this be addressed? Copying should just involve highlighting and pressing Ctrl+C. Or otherwise provide a ‘Copy’ button/action, which would be amazing!.

But even when I get the little ‘Copy’ bubble and click it, it doesn’t actually load the text into the clipboard. This is a key part of my app - please let me know what can be done.

Thanks!

I’m also having this issue on the PWA of a web app, not sure about the iOS version.

Hey @parker it looks like im seeing the same issue on the PWA of my app but it’s copyable on the same version of that in iOS so it looks like it’s an isolated issue with PWAs. created a Triage dev ticket for it to get fixed. thanks for catching this.

1 Like

Awesome, thanks! Glad to know it will work in a published app.