Custom Component Publishing Error

I’m trying to publish my custom component and am getting this error:

It doesn’t seem like anyone else has experienced this. Also difficult to troubleshoot because there’s no explanation for the error.

^ this is after I run npx adalo publish

I get that often, most of the time it is caused by not running npx adalo login prior to publishing. If that does not solve the issue let me know and I can give some more guidance on debugging.

Okay, I just tried to publish a new component and I get undefined, but this time it is a bug in their CLI probably related to Link to Demo App.

To fix this problem you need to roll back to an older version of the CLI. open package.json and find "@adalo/cli": "0.0.48," and replace that with "@adalo/cli": "0.0.42," after that run yarn to install the old version of the CLI and publish again.

It will solve your issue

That’s weird, i was using 0.0.48 and publishing normally, but good to know

I was fine up until 10 minutes ago, then I got a 503 error. Reverting back to 0.0.42 let me publish.

I think they are deploying changes to the component marketplace in preparation for Monday beta and they made a bug. Probably will be fixed later today, for now 42 works

oh okay, i see…

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.