Disappearing External Collections

Wondering if anyone is experiencing their external collections (particularly from Xano) disappearing after approximately 1 second?
Video here: https://www.loom.com/share/41a1cd6d3c0c4d0b9301c6c5779ad33c

This is happening only for the ‘addon’ data from Xano. Data from the original GET request seems to stay fine (addon data is the red circled area for me)

Any help is greatly appreciated!

Hi Joseph,

That’s weird! Is it possible to show the setup with a video? Is it happening now? What happens if you remove the Addon and click Save and add the Addon again and click Save and check again the app?

I just checked and this is how it works for me :

Thank you

1 Like

Hi @dilon_perera , yeah it’s super strange.

Im still having the issue and I tried doing what you said. I also tried deleting all my records and re-populating them but Im still having the same problem. Most recently, I tried creating an entire new instance in Xano but still no luck.

Here’s my setup: https://www.loom.com/share/ef86ca0d6ba9437781598a7b26d60f7b

Hi Joseph,

Sorry for the late response!

Thanks for that video!

I have watched it and I did the same as you did and finally I also faced the same issue. And after I rename the creator column in the posts table to user_id and refresh the external collection and delete the magic text and add it again then it worked. But when I renamed that column to creator and refresh the external collection and delete the magic text and add it again and then it disappears.

Here’s a video :

Thank you

1 Like

Hi Dilon, all good.

That was some amazing sleuthing! I just tried what you did and that fixed it up. Weird how it doesn’t recognise changing the property name in Xano. I hope you’ll be okay if I shared your clip in the Xano forum? (https://community.xano.com/c/connect/disappearing-data-on-frontend-adalo#comment_wrapper_6852673)

Thank you for your great help!

1 Like

No Problem and Your Welcome!