Edit record from Xano

Hello Everyone

I managed to connect an external collection (Xano).
The following is working:

  • Displaying data
  • Deleting Data
  • Adding Data
  • Filtering Data

However, I have not managed to “Edit” ar recod by using the “update current record” action.
Somebody know how to set that up?

Regards

Adriano

Hi Adriano,

Check out this page:

Hope that helps!
-Firoz

Hi @adyking,

I believe that you need to change the Update Endpoint in the External collection setup to POST!

Because in XANO for Update it has POST!

image

By default the external collection has setup-ed as PUT!

Maybe Prakash ( @xano ) can confirm it? Or a experienced maker? Or maybe Legends that I know using Xano : Bhanu ( @bhanu ) and Nathan ( @theadaloguy ) :slightly_smiling_face:

Thank you

1 Like

Very cool, it worked now. Thank you very much for all your tips.
I have changed from put to post and its working.

1 Like

Just a heads up (I might be wrong) but I find that I have to set every single value for the record every update from Adalo to Xano. If I leave “No change” it will be blank. Or am I missing something else?

Also you can change Xano from post to put for update.

image

image

Disclaimer: I’m new to both Xano and Adalo…

Hi @Meibe,
XANO user here. the POST or PUT or PATCH in XANO will not change the blank situation, you will need to create a specific Endpoint in XANO for the fields that you only want to Update and hide the other fields, similar to this:

Another option is, to always update all the fields even if there is no change, but in my opinion, a specific endpoint is better and safer.

By default, XANO comes with POST for update and create requests, but you can always create new Endpoints with PATCH or PUT, it will be the same.

Let me know if you have other questions.

2 Likes

Thanks. Great advice for updating only a few values! Hadn’t thought about that.

hI jl_LJ it looks like you are quite an expert in Xano… so maybe you may also help me with my other issue: I am not able to use the date+time picker in adalo to create a timestamp-record in xano. I have almost tried everything (including changing the format…). Can you help?

Thanks in advance

adriano

Hi @adriano,
Can you send me a screenshot of the custom action and the XANO field you want to update? The date is incorrect or what is the issue?

Hi @JL_LJ

The problem when I create a record in Adalo with a date+time picker the date is not displayed correctly in xano.

I will show you an example with screenshots:

Let say I want to create a record with the following date/time: Tue, May 31, 2022: 7:19 PM. In the screenshot you also see how it is formatted

When I the take a look in Xano the date+time is wrong.

Hi @adyking ,
One thing to mention from beginning, XANO by default is UTC (1 hour less of CET). Xano stores timestamps as a Unix timestamp in milliseconds as UNIX EPOCH.

Unix epoch timestamps in XANO are in milliseconds and in UTC calculated from 01/01/1970.
When you have the date in Adalo you can convert to epoch

Try using this formula: your DATE (In your case Start date) x 86400 (Number of seconds in a day) x 1000 (to convert to Epoch Milliseconds).

Similar to this:
image

And then just send to XANO.

image

If you want to test results, use one column with just date in xano and the other with date in CET, to check the 1 hour difference.

1 Like

@JL_LJ thank you very much. You are the real Adalo King!

1 Like

:slight_smile: , Haha thanks a lot, appreciate it, Just helping out as many in this great community :).

Hello

It’s me again, sorry for bothering you again… :frowning:
So I followed your advice and everything worked fine (see Screenshot) → I calculated the time by implementing a formula in my first app.

image

However, now a couple of weeks later I wanted to implement the same in another app and it is impossible to create a formula (also a workaround with customized formula) is not possible. See Screenshot two. That is very strange as I am doing exactly the same as last time. Does someone has experienced the same. (You see that is not possible to create a forumla as “x” is not green).

Hi @adyking,

To get them the property needs to be a number property. Did you checked that? Maybe this is a text property. If it’s text you should see a section called custom formula to add formulas!

Thank you

1 Like

As @dilon_perera already mentioned and on spot, you are using text property, there are no calculations the way you set it up, if you look into the “x” it is black colored, not green colored, this indicates that is it not a formula, also the magic text is a “T” and not an “X”

Formula
image

Not Formula
image

So you need to use Custom Formula as @dilon_perera suggests.

1 Like