Error adding domain and ssl


I want to add my custom domain to adalo via namecheap. I fully setup CNAME record, it seems like looks okay.

nslookup -q=CNAME

Non-authoritative answer: canonical name =

But at the same time when i click to Finish adding domain there is an error.
Also i can visit but it will raise Not found, thats okay, because nothing on this domain yet, but i cant understand why its not https but http

Summary: what i have to do to finish adding domain and how to add ssl ? Thanks

Welcome to the community @mikeqq :tada:

I checked your CNAME and I see that it’s properly propagated, and it looks like it’s correctly set up.

I would recommend waiting a bit before trying to finish the set-up again. Maybe there’s a propagation element on Adalo’s side.

If the issue persists, then better open a ticket with Adalo support.

1 Like

I understand that dns can take up to 48h before full setup, but i add record 2 days ago :slight_smile:

Also, could you please provide instruction how to add ssl to my domain ?

Hi Mike,

Not sure. Just a thought :slightly_smiling_face:

In the Namecheap Documentation it says wait until 30 mins :

And I saw that in your screenshot it’s 5 mins. Maybe wait another 25 mins or some time and try again.

Thank you

SSL is provided by Adalo.

@dilon_perera it just an alias record, not cname, it doesnt do some very important things. I can delete this record and nothing will change

Oops :slightly_smiling_face: Sorry! Does it works now?

@dilon_perera nop, now i cant even add domain. It says that my domain is not available. But it is :slight_smile: I can still visit and look via nslookup

@dilon_perera any suggestions ?

After looking at your URL, this is a good sign:

This means it’s pointing to Adalo. It’s just not linked up.

So go into your domain settings. If the domain is there, try removing it and adding it again. Take a screenshot of what the result is when adding the domain, just like you did in the first post in this thread.

Hopefully, it works this time.

After you’ve added the domain again, click on the “Publish” settings and set the domain from the dropdown. Keep the input field blank. Click save.

1 Like

@Flawless thanks a lot for adivce. But … :slight_smile: I will attach screens. May be its be me doing something wrong or i didnt found something


Dang. That sucks man. Have you submitted the support ticket yet?

The error says it’s not available. That means the subdomain is already in use with another app inside Adalo.

Open a ticket with support to clear that. Or, if you where you used the domain, then go back there and remove it.

1 Like

Hi @mikeqq,

I’m not good with setting up Domains :slightly_smiling_face: but I believe Charles and Mario is correct here!

If you try one more time after reloading the tab and if not work the best option would be Submitting a support ticket!

Hope it will be fix soon!

Thank you

@dilon_perera @Flawless thanks for help, something happend and it became available :slight_smile: love you <3


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.