External Collection lists not displaying?


I’ve been trying to figure out why my Ext collection lists aren’t showing properly and I can’t come up with the answer. Literally every test that I run through Postman and Adalo itself shows no errors but when I actually log in (with External User beta) the data isn’t shown. I checked if the Authorization is correct, triple checked my privacy settings on the backend, tried different privacy rules (even full access) and checked if the login is actually successful.

Any thoughts on what would be my next move? Weirdest part of all is that I’m running two apps from this backend and my other one is working fine.

Here’s a few screenshots that show my test results and one of my privacy rules. I’m using the exact same authorization as my tests and I’m logging in with an account that has the role Consumer.

Could use some help here… Even with privacy set to full access for everyone none of the lists display anything. Is this a bug or am I missing something?