Form text inputs not accepting focus

Hey all, I have an app that uses a form to ask the signed-in user for profile information after they have signed in with an identity provider or using email/password.

Until recently this all seemed to work fine. We’ve just hit a few thousand sign-ups, which may or may not be related and this onboarding form now has some problems:

The web app becomes unresponsive (like you get if there’s a javascript loop that locks up the UI), warns the user that the page is unresponsive, and if you wait, it does become responsive again but you cannot get keyboard focus to fill in any of the text fields. If you tap in the text field you see the caret appear, but it immediately disappears as you’d see if something changed or removed keyboard focus.

In the Android app version this is the same, but worse, because it never gains keyboard focus at all.

So users are signing in, we get their email, and then they are seeing no value from the app because they can’t make a profile.

This is pretty serious! I’ve raised a support ticket but Adalo only operates Monday to Friday with an estimated 24-48hr turnaround on tickets, so can anyone help me here who has seen similar?

The app you can reach here: Go! Download the Dig-In App now!

So far, our original iOS build which we haven’t changed for a few weeks seems unaffected - I can’t replicate the problem there, so my current assumption is that something has changed in the Adalo platform which means that the Web and any new Android builds we do are failing in this way.

Thanks for your advice in advance, folks!

Stef

Hi @stef :wave: :wave:

Yes I saw your app and I faced that problem too.

It has to work. In my app it’s working.

Stef did you tried that auto focus option?

I think this might be a bug. Try to raise a support ticket on monday.

Others also share their experience Stef :blush:

Thank you :blush:

Thanks Dilon,

I managed to resolve this by removing a n-to-n relationship in the data model. Apparently when the user profile form was displayed, in the background the react app would query all of these relations and seemingly force a rerender of the react interface on each row (or something like that). This made the CPU max out, a delay while downloading and then a slow interface as it processed all the rows.

Removing the n-to-n relationship fixed it and stopped this behaviour. Not ideal, because we wanted that data in the way it was set up. I think the solution long term would be to use a custom back-end for things like this.

Stef

Your welcome Stef. Happy to hear you problem solved :innocent:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.