Getting 500 error when creating record in Adalo via API

I’m using Integromat to create a new record in Adalo, but I keep getting an error. I tried in Postman too and also get the same error. I can’t for the life of me see what’s going on. I’m even trying to post random text/numbers so there’s definitely no arrays being passed.

Here are the Integromat and Adalo screen shots. Anyone (@Victor) have any ideas?


1 Like

@paulh 500 error usually is server side error and not the client side.

Are you able to share error logs from postman?

I think you’ll have to submit a support ticket if there’s no definitive information from the error logs.

1 Like

I too have been getting these all night out of the blue. Getting them on Integromat scenarios that have ran thousands of times successfully until tonight…

Last time this happened because an app was hitting the API too hard and was bringing down the server.

In the meantime, it’s best to submit a support ticket.

I can confirm I also got this the last 12 hours. Before that it has been working for months, and I did not make any changes. So there is definitely a problem on Adalo’s end.

1 Like

Hi @paulh and all,

Just for information - I see several errors in my scenarios as well (get 403, 500 and 503).
I’ve informed someone from Adalo about that, hopefully it’ll be fixed.



I am currently looking into this. So far I can confirm I am seeing issues on POST and DELETE requests hitting the Collections API.


This is still not working as of 1.45pm ET…

1 Like

Us too. Coming up on 24 hours of not having live data in our app…

Just tested and it seems to be working again.

Communication from Adalo would have been nice…


Hi everyone,

Works for me now - tested in several scenarios.

I guess it was a hot day - AWS had some problems as well, you can see on Downdetector - which affected everything on the backend.


I got it hard. I actually think it was caused by my audio recording component. I moved to Xano to store data.

Sorry for the late reply in here. There was a multitude of issues that were affecting this yesterday and it took much longer than expected to get this resolved. However, this should be resolved now!


Luke 12:2-3


reply testehtehtsh

I have currently some trouble while setting up new external collections (403 error) and it seems that the header data with the bearer key is not transmitted. Running the API call in Xano’s “Run & Debug” Mode works perfect.

Should I send a ticket to adalo or does anyone else has trouble here too after yesterday?


External collections would not be an issue on our side if it is returning an error. It will be an issue with the api provider you are trying to request data from.


Ok, thx. Will ask xano then.

You spelt Bearer incorrectly in you screenshot, hence the issue.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.