Help Lists in Airtable

I am migrating the Adalo database to Airtable, and I am having difficulty managing linked lists.

I have to manage Categories and Subcategories, I can’t show only the subcategories associated with your category.

For each category I display all the subcategories !?

Where am I doing wrong?

will be easier to figure out the right move… if you join a capture of your Screen

Tip *have you tried adding a 2nd filter - just below the 1rst one ?
- specify just the subcategory criterias in this one.

…if this is what you re trying to achieve… :man_shrugging:

Thanks @bibipac for the reply.

I have two simple linked tables: category and subcategory. Each subcategory is associated with a category.



I would like to show the records like this:

Category 1
subcategory 1
Category 2
Subcatgory 2


I set the filter like this:

what I get in output is this:

It is as if the filter has not been read.

Sorry @Ben, @jeremy, @ashley, @karimoo, @bibipac I ask for your help because I don’t understand if the problem is the filter set or an Adalo bug in recovering data from Airtable.

I tried in various ways: if the value of the category associated with the subcategory is entered manually, the filter works but from the magic text it does not work, that is, it extracts all the records for each category.

Would you please anyone who can help me understand where the error is in this view?
Thank you

Would set up of : “Maximum value” (in sorting) to 1, …solve the issue ?

Extracting 1 record (maxRecords = 1) does not resolve issue.

Did you set it to 1 … for Category, …or Subcategory ?

If I set maxRecords = 1 on the categories: it extracts a single category and below shows all the sub categories (even those not associated).

If I set maxRecords = 1 on subcategories, it extracts only one subcategory but is not associated with its own category.

If you have a list (“list 2”) inside another (“List 1”) with data from Airtable, how do you filter the data of list 2 based on the key of List 1?

How do you set the “filterByFormula” field?

Not at my pc right now, though…
I think you only need to display the subcat list - then within the subcat frame, add an empty field, (using +)than grab the cat name through a custom formula…like “”…and it only - smartly ,:yum: lookup -and -add this name beside each… (or above, depending where you place the field)

I tried this workaround, but the result is that for each sub-category you repeat the name of the category … does not seem very smart… :wink:

hmm, yes that is the target, but you are saying its still not displaying the result as your wanted scheme below ?
(…with the extra MaxRecord =1)

Ok, i m back to Station :upside_down_face:
So, this is what i can get…
1/ choose to add a new “LIST” (not just a Field Imput) for Subcat Name. (within the MAIN cat frame)
2/ maybe you did not chose the “current Subcat” …so as to get ONLY the 1 to 1 Corresponding Subcat Value.
3 / do NOT use MaxRec 1… My bad… :speak_no_evil:

Capture du 2020-07-23 11-10-10 Capture du 2020-07-23 11-11-28 Capture du 2020-07-23 11-11-51 Capture du 2020-07-23 11-12-18

I have just heard today that React Nativ relies a lot on Nested component… so that is the way to think of when doing that kind of stuff

Maybe you d want to support this component REQUEST for a practical compact Data Display :heart_eyes: Compact GRID 2x2 to 5x5

Hi @bibipac, thank you for your availability but I don’t solve the question.

Adalo-Airtable … filterByFormula doesn’t work for me.

If I use the Adalo db there are no problems in obtaining nested lists, but with Airtable it is impossible.

Do you use Airtable? Do the “filterByFormula” parameters work with magic text? Not me!

What is surprising is that none of Adalo employees give support in these cases … especially considering paying customers.

With these bugs Adalo is unfortunately limiting.

yep, bummer…I try to get as much juice out of Adalo as possible, so no, I am not a big fan o relying on 1,2 or more providers…for the same reason/problem you are dealing with - though I totally understand you re stuck because both providers do not link perfectly. (On the other hand does Adalo really have the culprit or maybe its a problem out of Zapier…or worse its an incompatibility for both teams are using different standards…so who’s going to do the first step ?.. :grimacing:)
…as you mention; quite some time can go before its solved by someone.
If this is crucial to you, than option 1/ you try to find a workaround…2/ you test another Provider with which the same process could bring better reliable results…
…I would try option 1 first and if you don’t come out with s/t in a month…then you know what’s the next step.
:no_mouth: Tuff non-coder world ! :grimacing:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.