Home Screen list not refreshed

Hi all,
I have a home screen with a custom list. When I open the app on the developement preview the list is refreshed and displays content.

If I make a test flight build and open the app on iPhone the list is empty. If I then select any menu item to go to another screen and back the list is refreshed.

Any idea how to solve this?

1 Like

I have the same problem here. i tried almost everything but the any solution i found was to use some standard list. It slowdown the app but… was the only solution.

I have further done some tests and the list works ok until you apply a filter. E.g. filter to display logged in users records. Could it be a bug?

For sure it is a bug! :frowning: I am using to display logged in user profiles. Since the design of it is important to me I created a “sync” button that goes to a black screen with a timer component of one second which trigger link back after timer is complete. That way user can “refresh” the list if there is no profile to select. Since i need the current profile data available in many screens it has to come from Home Screen.

1 Like

All the lists and the app itself is unbelievable slow today. I don’t know if they are migrating services to AWS from Heroku, or whatever they are doing, but I hope they are doing something. I am spending so much time trying to fix problems with Adalo that I should be using this time to code. I thought will be faster to implement with no-code but it looks like it’s not!

1 Like

Bruno, Thanks a lot for the description. I just started testing a “refresh” screen to get the profile data to my screens. Thanks!

1 Like

Sure. Another nice way is to use a Lottie animation of refreshing icon when trigger back when animation finish

Could you break it down for me in a step by step on how to reproduce this so that I can do so myself and report the bug to the team?

Thanks :slight_smile:

2 Likes

Sure @Colin
Custom lists that are filtered with logged-in user parameters do not load in the Home Screen. That only happens if the list is on the home screen and after closing and opening again the app. After login, it opens ok, but if you close the app and open it again then the list is hidden and you have to navigate to another page and come back to the home screen in order to see the list. I had to use my home screen as a blank screen with link action on load in order to have a profile selector every time users open the app.

How do you add an action on load?

here >>>

@Colin I have an app that does this as well and would be happy to show you what is happening. But basically any list on the “home” screen with some filter applied, when you first load the app will appear blank as if there are no items in the list that match the filter. If you leave that screen, and come back, it then has the correct items in the list being displayed. I have tried tons of work arounds, but can’t figure out something that really works well. The method listed above is the best option, but makes for a poor UX when loading the app each time.

1 Like

Hi everyone and @Colin I have exactly the same problem with my app, a list on the home screen like an instagram feed, I see the feed 1second and it disappear.
We have to visit an other page and visit homescreen again for seeing the feed. .

Have you all submitted this as a bug using the support form. I think it would help if you could include a screen recording of the issue too…

i fixed my home screen issue by removing the REQUEST PERMISSION on page actions. It fixed it for me.

@TonyD yes, Colin said me than the support is currently working on it
@CopyThat i’ve tried this and it doesn’t work for me.

1 Like

Same here. Removing the Notification Permission Request makes no difference.

1 Like

Hmm - so one thought on the remove thing not working… Could it maybe be the order of other actions in the stack? @CopyThat - what other actions do you have going on in that stack, or in what order? Could be something that deleting all actions and rebuilding the action stack might help with?

Hey @Colin this is a bug that was reported several months ago. It hasn’t been fixed yet as I still have this issue.

1 Like

Hey everyone,

Just to be clear that the forum is not the best way to report a bug or receive support as mentioned previously in our Adalo Statement of Support. @ Tagging me won’t help as this does not affect whether the issue is received in our support system or not.

Submit a Support Ticket is the fastest way to receive support on an issue like this.

Now on to the issue at hand. :slight_smile:

I have been able to reproduce this to a certain extent and I have made this a high priority on our bugs list. This will be looked at and resolved as soon as possible. I cannot give a time frame for that as it is out of my hands and priotised by the product team then worked on by engineers.

To speed up this process, it would help if everyone lists the app ID that they are experiencing this on so that I can look at each individually and assess for the pattern of the cause.

3 Likes