How to filterling by date property in collection?

How to filterling by date property in collection?

I created a screen which has 3 components.

  1. DatePicker input.

  1. Text component. it shows a number of records which match with date value inputted on DataPicker.

  1. List component. it shows a collection named ’testdb’ which has Text and Date properties.

In preview, at start time, it found one record.
But, filterling does not work when DataPicker value is changed. It cannot found date value.

Let me know if any mistake?

Hi Masushin;
I 'm not sure why you want to run the filter for datepicker on the date"Count" field…
If what you want to do is :

  • Select a date in the datepicker
  • display only ITEMS with date “Equal to” date picker

…than this is what I have tested - (works each time I m selecting another day in the Datepicker)

02 datepicker 03 datepicker 04 datepicker


I 'm not sure why you want to run the filter for datepicker on the date"Count" field…

Oops, sorry. I uploaded the wrong image.
I have a similar filtering setup for my list.

Anyway, thanks to your comment, I figured out how to get it to work correctly.
I set the DatePicker Style to ‘Date Text Input’ and it works correctly.
(By the way, why it need to be specify time value not only date value in case of ‘Date Text Input’…? )

However, I don’t need to specify the time in my use case, I would like to use only Date value, but it still doesn’t work. ( following image.)

Date + time … I could not say why, its Adalo choice i seems…
As for the uncomplete result, I would check maybe without the Kanji caracters - if you can search wih only A-Z 0-9 caracters, if that works without Kanji than you could say the Kanji search returns some bugged results…maybe, not a 100/100 sure method I m telling you

Hmm, this issue maybe related to language environment…?

About filtering for text property, even if it includes Japanese character, I have not seen any problem.
Collection filtering for Date property is unstable or not work correctly in my environment.

I’ll post this issue to Bugs category.
Thank you for your response.

hmm, have not tested for more than a few dozen clic on only 4 values - so as for now - mine is always stable but its a small test run…

let me confirm, It means that Date property (in the collection ) filtering using ‘Date’ Style DatePicker value ( not ‘Date Text Input’ style ) work correctly in your environment ?

( I don’t understand that different of ‘Date’ and ‘Date Text Input’ … )

Yes, that is the only type I ve tested : Date style picker. which worked fine :blush:
(never tested manual input style)…

(right now - it all stopped working ! :see_no_evil:
maybe the Team fixing something as of Sat 20)

I see.
For now, I’ll wait for some improvements.

Your comment was very helpful.
Thanks to you, I’ve found a temporary workaround for this problem.

Thank you.

1 Like

It was working correctly for 6/22 (yesterday).
But on the 6/23(today ), the filtering does not working again.

In my environment, collection filtering by date value is still unstable…

1 Like


I´d like to know how you changed the language of the Date Picker ?