Images from URL not showing

I have files that are saved it the Adalo database & then I list the files that belong to a user. Using the in-build Simple List component the left section set to Images, with the source as URL - shows any images, if there are any.
As I need more functions I have created a list of the same collection, using the Custom List component. But when adding an Image component and setting the source to URL as in the simple list… the image do not load!

1 Like

Hi @dasuksta,

That’s weird :-/ Checked in my app - images by URL in custom list works fine. May be there is some glitch?
The only advice I have - you may try to recreate the custom list…

Heyyy !! You have to add “&w=600” after the url for it to work !!! <3 I got u

Hey guys thanks for the feedback - tried both things:

  1. Created a new custom list
  2. added the suggested &w=600
    nothing! Even the place holder image is not showing - re-created this about 20 times, must be something simple i’m missing :frowning_face:

I’m a bit confused. Are these images coming from an Adalo collection? If yes, then why not just use the magic text option?

If they are coming from outside adalo, then could you post an example of the URL of one of these images? It could be possible that they are not https, which would not let them display.

Hey @Colin just to explain what I’m doing… I am giving my users a “Storage Quota” so they don’t load hundreds of unnecessary images. When uploading Images though the Adalo Image selector you cannot get the file size, but you can when using the File Uploader.
So I am using that component when users upload any file/image and using the Size attribute to track their usage.
My issue is two-fold:

  1. When using a Simple list (see attached screenshot) the image url shows the image.
    But when designing a custom list and selecting the collection and setting url for the image source - it doesn’t show.
  2. Also on the simple and custom lists - the Place holder image is not showing.

Hope that makes more sense - if not jump onto the app if you want :slightly_smiling_face: :+1:

Showing Images in Simple list - Image source set to url

Custom list of same collection - with image component set to image url, not showing

Ok, understood. I will have to investigate this further and get back to you. I have this on my radar but I just need to get through a rather large backlog on my to-do list right now but will get to this as soon as I can!

No worries bro, I’m working around the issue for now and shall await your update :+1:

I have worked out why this is happened. We are appending the URL of a URL with a query parameter when it’s coming from our database. This is causing the image to not work. I have reported the problem to the dev team.


Hi Colin, is this related to the URLs from google drive as well?
My images and audios stored in google drive, also doesn’t work in Adalo.

Top man :+1: thanks for looking into this :slightly_smiling_face:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.