Invalid Login using external data using xano

Hi,

Trying to use xano user table to login to Adalo, it is working fine, however, if user email/password are invalid, I get a pop from adalo “An embedded page at previewer.adalo.com says Login Failed”, however the action move to next screen displaying last successful login token and userid

It seems Adalo is caching in the last used token and userid.

How do I tell Adalo action if login is invalid to remain on the login screen or when I preview the app to clear last used token

TIA

Hi @hicham,

Welcome to the community :partying_face:

Try adding a condition on your link action like this. : Signup failed for external collection user signup API call - #4 by dilon_perera

Thank you

Hi dilon,

Thanks for your feedback, I tried this with External user auth token and userid but it still get a popup error from adalo and advances to the next screen.

Thanks

Hicham, just checked and it’s working for me!

Did you tried deleting the link action and the external login action and adding again? If not works you can give me access for your app for this email ( pereradilon24@gmail.com ) via clicking the gear icon > app access section > and add the above email and I will check this!

Thank you

Hi,

Thanks for your help

This is the app and this are valid username and passwords

Email: hicham@mail.com password H123456789
khaled@mail.com password: K123456789
mosbah@mail.com passwor: M123456789

[

XANO
previewer.adalo.com

](XANO)

Best regards,
Hicham

Hi @hicham,

Thanks for giving me access for your app!

Can you check again and let me know? I just deleted the Link action and added again and worked for me!

Thank you

Hi dilon,

It worked, many thanks.

Hicham

1 Like