iOS build keeps failing

we are trying to compile our app and get it on TestFlight. However, it keeps failing due to the following reason.
[fastlane_core] fix package upload after two-step rescue. (#18373) via Maarten Billemont

The error message in the log says the following
[precheck] update error message for Precheck cannot check In-app purchases with the App Store Connect API Key (#18251) via Lachlan
[spaceship] Better error handling of 403 status code when using API Key (#18299) via Dinsen
Please update using gem install fastlane

What we’ve tried:
entering all the credentials again, new app-specific password, new app/bundle in the appstore connect, new identifiers, publishing blank up with one screen even to a different account

We tried to reach out to the support, but without any luck.

Is anyone having the same issue?

Thank you in advance.

We are having the same issue… No idea how to solve it…

@Skychatters @JerryCDO

Could you guys submit a support ticket for this issue? Make sure to take a screenshot of the error.

Yes same issue as well about fastlane needing update. Sent ticket wednesday and waiting on reply. I sent the log in a txt file. Fingers crossed.

we’ve already submitted a ticket on Friday including this screenshot

Haven’t heard back yet, but trying to solve this issue as fast as possible, since we rely on the app, because we already have partnerships running.

Thank you for your help.

1 Like

I’m getting this same error over and over again tonight. Please let me know if you make any strides in correcting this! Thanks!

Edit - I don’t know if this was the solution, but I turned off all Adalo APIs (Integromat), and the very next test-flight build worked.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.