Issues with a default value for a dropdown menu

Hello all,

I’m working on an edit profile screen and would like users to edit a property in their profile through a dropdown menu. There’s a “default value” option available for the dropdown menu, but I’m not able to set the value to whatever option they’ve originally selected. Does anyone know how to fix this and show the value that’s in the collection?

Screen Shot 2020-04-09 at 2.18.53 PM

Screen Shot 2020-04-09 at 2.18.44 PM


Create a relationship collection

You should be able to pick that by going into the sub-menu under Logged In User in your screenshot, and then picking the relevant property.

When I go to the sub-menu I’m not able to select any user properties. I’ve tried creating relationship collections between “Industry” and “User” and I still am not able to see the properties. Do you know what could be going on?

1 Like

What is the dropdown a list of?

It’s the properties in the “Industry List” collection that has 60 records.

Screen Shot 2020-04-14 at 10.50.34 AM

@Ben do you know what could be the issue?

It looks like on your Edit Profile (old) screen you can select Logged In User > Industry List as the default value

@Ben I have a similar issue with setting the default value:
I need to assign a default role for a new user when signing up:
I am using the following settings for the form:
I can not select any of the 3 roles.
Instead, I see the following (which does not look right):


@karimoo were you able to figure out what was going on above? I am running into this same issue and have not been able to figure it out.

1 Like

What is this list of lists
I run into this constantly when I am trying assign a value from a collection that is a list of roles or functions. It will not open the collection and let you simply select the data entry you want, rather it just goes into a loop of parent child relationships.

Hi All,

Have you found the solution?

I have an issue: when the default value of the dropdown menu is ‘empty’ a user cannot pick anything before choosing “Select…” from the dropdown list. It does not appear even as a placeholder. Only in a form it works well.
Please, let me know how I can set up “select…” as a default value for the dropdown menu. Otherwise it is just blank and when a user tries to select anything it does not work. The only way it works is to pick 'select…" first and then to pick something else. This is not intuitive and I am not sure users can actually get it.
I guess this is something to deal with cache as it works the first time, but as of the second time it appears as blank. And unfortunately for the dropdown menu I cannot change input value…



Not sure if the screenshots can help but still…

@Ben I have the same problem. I have a List which I want to filter based on a status which can be selected from a dropdown “select menu”. There is a collection with about 5 entries for all possible statuses. I also want to set a default value when the user first visits the screen and set the select menu to the status “new”. This, however, is not possible because the default value can only be a reference to an object and not to a specific entry in a collection.

I created a sample App so you can see how can this be accomplished.

The username is and password 1234.

When you click on the button it will take you to a default category. You’ll see that the button is a list of categories and I’m just filtering for the one that I want to be the default. Then when you click to the next page Current Category is in the available data for that screen. So you select the dropdown and on the Default Value select Current Category.

I hope it helps.

1 Like