Map address format

Is there a certain format for the address to use with the maps component?

I tried Area, City, Country - and sometimes it works, sometimes it doesn’t.

I tried co-ordinates, it didn’t work.

I’m really confused and couldn’t find documentation on this. Anyone?

The map element is really pretty poor, and I would avoid using it if you can.

Address, lat,lng and PostCode all work for me. But sometimes the map will just not display. At all. This may be because it finds an address it can’t geocode. Quite why it is doing it on the fly (most other platforms do it on the database) is beyond me.

What you can maybe do is add in a limit on the markers, as this seemed to work for me although I don’t know why. Raised this via support, and as usual they just shrugged.

For anything Geocoding related , bear in mind Adalo can’t even sort on distance despite saying they are “mobile” app platform, I would look elsewhere.

I have the same problem…

Hi @Shinnawy @Victoire29 can you let me know an example of an address that is providing an issue so that I may troubleshoot the problem.

The map will disappear when an address is null.

If it is not a recognised address then it will default to Pittsburgh.

Here are a few examples:

1- New Cairo City, Cairo Governorate
2 - Mountain View 1, Second New Cairo, Cairo Governorate
3- Giza, El Omraniya, Giza Governorate
4 - 30.016445, 31.442526

@Colin Did you manage to check those out?

All 4 of those locations worked fine for me @Shinnawy

image

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.