Missing data in list (Adalo with Airtable)


I have a problem when accessing a collection in Airtable, there are 126 records, but when these records are shown in a list in Adalo, it only shows 63, that is, half of the records recorded in the collection.

Does anyone know any way to fix this, maybe some parameter I have to pass on the list.

Thank you

Airtable has a limit of 100 in “one call”, but bring only 63 is a bit. Can you try rebuilding the external collection again and see the results? Sometimes I get issues with Airtable not bringing all fields, so the connection is not properly made.

Yes already made the connection again and still the same thing. See the URL below, even though I put 130 records, it didn’t work


@rafa.ntt remove the max records parameter in the URL and try again with the following url.


you should get 100 records in the call, if the issue persists, check your Airtable for blank rows or data if any on the first column. If the issue still persists, try to call run the Airtable API in postman to confirm it’ss not the issue before raising a ticket to Adalo’s team.


@bhanu It´s workin now, I have 100 records in Adalo´s List. However, there are 130 records that need to be shown. How can I do that ?

You need to work with the offset, unfortunately don’t think the Adalo Call works outside of the box.
What is the purpose of calling all data?

Do you really need all the list to be shown? Isn’t it better to work with taxonomies (Categories and so on) and filter the data? Also will make the App run faster.

@JL_LJ there are 130 product codes that the logged-in customer can choose to launch a sale, so I need to show the 130 products in the list